lostpacket
Level 2: Rookie

IPv6 gone after april 2019 updates

Answered

Hi,

On telstra NBN fibre, and have had a IPv6 prefix since the fibre was connected (approx 2 years). After the network updates today, its gone, and my router just times out requesting a prefix. Is it broken for everyone else as well?

 

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
yek
Level 2: Rookie
Accepted Solution

Re: IPv6 gone after april 2019 updates

I've raised a case with Mikrotik on 11/05 regarding option to disable default rapid-commit, and their reply was "We will consider implementing such a feature in order to resolve the problem with the server that does not work based on the latest RFC version of the DHCPv6 server. Additionally, we do recommend that you contact your DHCPv6 server administration and let them know that their server is outdated."

 

Mikrotik added this option in 6.45beta50 yesterday and it works, I now have IPv6 working again.

Was this helpful?

  • Yes it was, thank you
  • No, I still need help
9 REPLIES 9
yek
Level 2: Rookie

Re: IPv6 gone after april 2019 updates

Hi,

 

I also had IPv6 on residential NBN HFC working fine with dynamic prefix delegation. It has stopped working around the same time.

 

I did some packet captures on Telstra-facing interface and it looks like this:

- my router sends DHCP SOLICIT message

- Telstra replies with DHCP ADVERTISE containing link IPv6 address and prefix

- my router sends DHCP REQUEST message with parameters from DHCP ADVERTISE and waits for DHCP REPLY

- there is no response from Telstra DHCP after this point

 

Thanks

 

lostpacket
Level 2: Rookie

Re: IPv6 gone after april 2019 updates

Hi,

I was using a Mikrotik router for my connection (fibre to the house).

There is a long thread on whirlpool with the details of the problem.

https://forums.whirlpool.net.au/archive/2767959

Its to do with the implementation of the the "rapid-commit" option in the dhcp client and server exchange.

I have loaded openwrt on an old Mikrotik, and IPv6 is working. It also works on the Telstra supplied router.

I sent the details to Mikrotik, and the reply was

"I recommend that you contact your ISP and let them know that their DHCPv6 server is not working properly.
We will consider implementing rapid-commit=yes/no option on our DHCPv6 client."

 

Interestingly, I received a text from Telstra yesterday, saying there would be an NBN outage on 13th May, so maybe its a fix for the IPv6 issue. I will post back next Tuesday, if its fixed.

 

 

 

 

yek
Level 2: Rookie

Re: IPv6 gone after april 2019 updates

Thank you, that explains the issue, I'm using Mikrotik too and there is no option to disable rapid commit.
lostpacket
Level 2: Rookie

Re: IPv6 gone after april 2019 updates

Hi
Telstra did a second update on the 14/05/2019, but the IPv6 is still broken on Mikrotik RouterOS
I have loaded openwrt on a second Mikrotik, and IPv6 is working on it.
Just keep waiting for Mikrotik or telstra to fix it :-(
Level 25: The Singularity
Level 25: The Singularity

Re: IPv6 gone after april 2019 updates

Rapid Commit is disabled by default on IPv6 DHCP servers. I'm surprised that Mikrotik wouldn't support something that is a default setting. No the brightest decision on their part.
Never be afraid to back yourself when trying new things, just always make sure you have 3 escape routes if things go wrong.
yek
Level 2: Rookie
Accepted Solution

Re: IPv6 gone after april 2019 updates

I've raised a case with Mikrotik on 11/05 regarding option to disable default rapid-commit, and their reply was "We will consider implementing such a feature in order to resolve the problem with the server that does not work based on the latest RFC version of the DHCPv6 server. Additionally, we do recommend that you contact your DHCPv6 server administration and let them know that their server is outdated."

 

Mikrotik added this option in 6.45beta50 yesterday and it works, I now have IPv6 working again.

lostpacket
Level 2: Rookie

Re: IPv6 gone after april 2019 updates

Hi,

Thanks for the update. It now works for me as well on 6.45beta50.

 

 

asli96
Level 1: Cadet

Re: IPv6 gone after april 2019 updates

Hi

 

I have the same trouble and just upgraded my router.

Can you show me how to add rapid-commit option by CLI?

 

Thanks

yek
Level 2: Rookie

Re: IPv6 gone after april 2019 updates


@asli96 wrote:

I have the same trouble and just upgraded my router.

Can you show me how to add rapid-commit option by CLI?


Hi,

 

Assuming that you have only one IPv6 dhcp-client in our configuration, you need to enter the following from CLI:

 

/ ipv6 dhcp-client set rapid-commit=no 0

 

"0" is the ID of your DHCP-client entry

 

Once rapid-commit disabled, you can renew address with

/ ipv6 dhcp-client renew 0

 

I hope it helps. 

Telstra Smart Modem

Plug in and connect in minutes. Smart.

Find out more
Find out more about the Telstra 24x7 App ×
Manage your services and take advantage of offers while you’re out and about with the Telstra 24x7® App Download now
Earn points on our new rewards program and enjoy tier benefits like discounted movie tickets and moreFind out more

Need a hand or want to share your expertise?
Register for CrowdSupport and get involved

Register now