CrowdSupport®
willywhite
Level 2: Rookie

Cisco 887 Config for Telstra FTTN

Hi everyone,
Wondering if anyone has connected a Cisco 887 or similar to a Telstra FTTN service? Telstra don't seem to use PPPoE for authentication (which is what I'm used to with Exetel and AAPT services). So this is the area i'm mainly wanting config for.

Any input or ideas would be great, maybe Telstra don't let you use third party modems? Is it only their supplied gateway max that works?

 

I'm running latest IOS on the Cisco and the FTTN service itself is definitely operational (tested with Telstra issue modem).

Thanks

Was this helpful?

  • Yes it was, thank you
  • No, I still need help
12 REPLIES 12
Level 24: Supreme Being
Level 24: Supreme Being

Re: Cisco 887 Config for Telstra FTTN

No, it doesn't use the authentication for FTTN.

Officially only the Telstra Gateways are supported, my understanding is that the authentication happens on a network level rather than at the modem, I have come across cases where people have managed to get it to work but have usually come to issues with it, also the voice service is only supported via the T-Gateway modem.

Any non-standard (non-telstra) modem will usually mean if you do have problems that Tech Support aren't much help because they are pretty much only trained in their standard modems.
Helpful Links

Internet not working or outage in your area? - Check the Outage page for details and troubleshooting.
Help with an account issue? - LiveChat 24x7 support
View Usage, Bills and more - Check it out on MyAccount

Previously worked with a Telstra Partner however I am not a Telstra Employee, just a fellow customer helping when I can.

Level 24: Supreme Being
Level 24: Supreme Being

Re: Cisco 887 Config for Telstra FTTN

You could check this thread: http://forums.whirlpool.net.au/archive/2488909

I am a Premium Services Support Consultant (Telstra Platinum, Telstra Smart Home, Locator/Device Locator and Neto POS). However, I am not an official representative on CrowdSupport.

IT Helpdesk and Technicial Support by Telstra Platinum
Smart Home Automation & Monitoring from Telstra
Helping Australians Find the Things that Matter Most with Telstra Locator
Run a Modern Retail Business with Neto Point of Sale
willywhite
Level 2: Rookie

Re: Cisco 887 Config for Telstra FTTN

Hi Yastiandrie

Thanks for the info - actually I was the poster in that thread you linked to Smiley Happy So i got the 887 working with Exetel however that same configuration doesnt work with Telstra FTTN - hence my question here. Wondering if it is possible at all with a Telstra connection. 

willywhite
Level 2: Rookie

Re: Cisco 887 Config for Telstra FTTN

Thanks DrQwerty90

 

Im very aware Telstra dont support any other modems and with good reason. I however need to run a VPN to another office which thr max doesnt support so would be very interested if its possible at all and then if so ill go off and try to find some config

Level 24: Supreme Being
Level 24: Supreme Being

Re: Cisco 887 Config for Telstra FTTN

You could try bridging the telstra modem and use the Cisco as a router via WAN
I am a Premium Services Support Consultant (Telstra Platinum, Telstra Smart Home, Locator/Device Locator and Neto POS). However, I am not an official representative on CrowdSupport.

IT Helpdesk and Technicial Support by Telstra Platinum
Smart Home Automation & Monitoring from Telstra
Helping Australians Find the Things that Matter Most with Telstra Locator
Run a Modern Retail Business with Neto Point of Sale
willywhite
Level 2: Rookie

Re: Cisco 887 Config for Telstra FTTN

Thanks Yastiandrie, 

 

Do you have any information on how to put the max into Bridge mode? And what the resulting setup might be on the cisco? I assume it needs to be given a DHCP setup for the WAN connection?

Level 24: Supreme Being
Level 24: Supreme Being

Re: Cisco 887 Config for Telstra FTTN

it is http://10.0.0.138 > advance > local network > network mode - 'bridged mode'*

 

advance.png

localNet.png

bridged.png

 

*In bridged mode, if you are someone who uses the phone service, it is worth noting that it will not work which if you don't need it is fine but something that I am just noting incase someone who does use it reads this at some point so they do know also Smiley Happy 

 

Helpful Links

Internet not working or outage in your area? - Check the Outage page for details and troubleshooting.
Help with an account issue? - LiveChat 24x7 support
View Usage, Bills and more - Check it out on MyAccount

Previously worked with a Telstra Partner however I am not a Telstra Employee, just a fellow customer helping when I can.

nicholasporison
Level 2: Rookie

Re: Cisco 887 Config for Telstra FTTN

The same situation is with me thats why i run PureVPN and for this issue i contacted to their support team and they helped me.
nicholasporison
Level 2: Rookie

Re: Cisco 887 Config for Telstra FTTN

couple of days ago i was facing the same issue and using purevpn for this.

willywhite
Level 2: Rookie

Re: Cisco 887 Config for Telstra FTTN

For anyone who this may be helpful to, I finally got this working (no bridging, VDSL terminating directly on the 887). Here is a complete working config. Please note this has only been tested as working with specific firmware:
VA_A_39m_B_38h3_24h_o.bin

 

Cheers
WW

----------------------

hostname RTR01

clock timezone AEST 10
clock summer-time AEDT recurring 1 Sun Oct 2:00 1 Sun Apr 3:00

 

no ip source-route
ip cef


multilink bundle-name authenticated


username admin privilege 15 secret XXPASSWORDXX

archive
log config
hidekeys
exit
exit

interface ATM0
shut
exit

interface Dialer0
shut
exit

interface Ethernet0
description --- Telstra VDSL ---
ip address dhcp
ip nat outside
no shut
exit


interface Vlan1
description --- Ethernet LAN ---
ip address 192.168.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
exit


interface FastEthernet0
no shut
exit
interface FastEthernet1
no shut
exit
interface FastEthernet2
no shut
exit
interface FastEthernet3
no shut
exit


no ip http server
ip http access-class 2
ip http authentication local
ip http secure-server


ip nat inside source list Outbound_NAT interface Ethernet0 overload


ip access-list extended Outbound_NAT
permit ip 192.168.10.0 0.0.0.255 any
exit

 

no cdp run

 

ntp clock-period 17180370
ntp server 129.143.2.23


webvpn cef


crypto key generate rsa usage-keys label router-key

1024

1024

 

line vty 0 4
access-class 1 in
no exec-timeout
privilege level 15
password XXPASSWORDXX
login local
transport preferred ssh
transport input ssh
exit

enable secret XXPASSWORDXX


controller vdsl 0
firmware filename flash:VA_A_39m_B_38h3_24h_o.bin
lldp run


exit
clock set 11:09:00 Sep 02 2016


wr mem

David_Belyea
Level 1: Cadet

Re: Cisco 887 Config for Telstra FTTN

For FTTN setup with a modem in bridge mode try this link

 

https://www.skycomm.com.au/how-to-setup-nbn-fttn-on-a-cisco-router-2900-series/

 

even has a you tube vid on it

BLackBirdIT
Level 1: Cadet

Re: Cisco 887 Config for Telstra FTTN

HI Guys,

 

has this worked for anyone for a Cisco 887VA

 

below is my configuration

 

___________________________________________

___________________________________________

 

Building configuration...

Current configuration : 8456 bytes
!
! Last configuration change at 15:42:20 ACST-DS Mon Mar 27 2017 by leetgeek
version 15.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname XXXXXX
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
!
no aaa new-model
memory-size iomem 10
clock timezone EST 10 0
clock summer-time ACST-DST recurring 1 Sun Oct 2:00 1 Sun Apr 2:00
!
crypto pki trustpoint TP-self-signed-260161448
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-260161448
 revocation-check none
 rsakeypair TP-self-signed-260161448
!
!
crypto pki certificate chain TP-self-signed-260161448
 certificate self-signed 01
  30820229 30820192 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32363031 36313434 38301E17 0D313730 32323830 34323432
  385A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
  532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3236 30313631
  34343830 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100
  93988D57 7FC16FC4 F79C2CCB 41252B9C 0AF2F1D5 6E71EA44 FDAD5A76 72FAFE68
  7092C4C1 C92CD774 E6B28B62 A3679225 46C62F71 9EB30028 83EADBA1 5A5BFB36
  70450F51 A0D9B34B 2CDDAB53 9D5E6D63 F989264B DFD22C27 B0218579 47C1D688
  C9906514 FA5EBAAB C581F2CC D7B490C8 D5347164 57C46D10 B53D08E1 CEBE3541
  02030100 01A35330 51300F06 03551D13 0101FF04 05300301 01FF301F 0603551D
  23041830 16801424 CD74B17A 67C7CBCB B22AFF80 E75A8E50 AC7D9B30 1D060355
  1D0E0416 041424CD 74B17A67 C7CBCBB2 2AFF80E7 5A8E50AC 7D9B300D 06092A86
  4886F70D 01010505 00038181 0064FFE2 1B2C29DA 891379C5 3D3BE988 B4C749E3
  82FD1692 0A768BE4 5A2AD6FD 86D6D253 37BDC75F 975FC92D C48237E5 EDB7A5F5
  A415E30A DA7945A8 A3F28715 69DD9F77 7E90C580 A8E199CB CCC14B93 024C5F10
  0FED4DF0 A2C60D1F 954106F4 7661981E 8B4EB834 A2A50CBF 49F29629 9542FC24
  E28FBAFD A8AE4E2E 8F5EE485 04
        quit
!
!
!
!


!
!
ip dhcp pool XXXXXXXX
 network 10.110.4.0 255.255.255.0
 default-router 10.110.4.1
 dns-server 8.8.8.8
 option 156 ascii ftpservers=10.202.7.1, Layer2Tagging=1, VlanId=110
!
ip dhcp pool LAN
 import all
 network 192.168.25.0 255.255.255.0
 update dns both
 default-router 192.168.25.1
 dns-server 192.168.0.250 8.8.8.8
 domain-name moveyourself.local
 option 156 ascii ftpservers=10.202.7.1, Layer2Tagging=1, VlanId=110
!
!
!
ip domain name XXX.LAN
ip name-server 139.130.4.4
ip name-server 8.8.8.8
ip name-server 61.9.194.49
ip name-server 61.9.195.193
ip cef
no ipv6 cef
!
!
!
!
!
multilink bundle-name authenticated
!
flow record nbar-appmon
 match ipv4 source address
 match ipv4 destination address
 match application name
 collect interface output
 collect counter bytes
 collect counter packets
 collect timestamp absolute first
 collect timestamp absolute last
!
!
flow monitor application-mon
 cache timeout active 60
 record nbar-appmon
!
!
!
!
!
!
!
!
license udi pid C887VA-K9 sn FGL210723YS
!
!
username XXXXXXX privilege 15 secret 5 $1$ws4t$JRVkC/N64QXoKGjQwdaIf.
username XXXXXXX privilege 15 secret 5 $1$VuKX$c5vWzXOOCBnJZ01M9qIjE1
!
!
!
!
!
controller VDSL 0
 firmware filename flash:VA_A_39t_B_38r1_24o_rc1_SDK_4.14L.04A.bin
!
ip ssh version 2
!
class-map match-any QoS-VoIP
 match ip precedence 5
 match dscp ef
 match access-group name QoS-VoIP
class-map match-any QoS-Gold
 match dscp af11
 match dscp af12
 match dscp af13
 match ip precedence 1
 match access-group name QoS-Gold
class-map match-any QoS-Bronze
 match dscp af31
 match dscp af32
 match dscp af33
 match ip precedence 3
 match access-group name QoS-Bronze
class-map match-any QoS-Silver
 match ip precedence 2
 match dscp af21
 match dscp af22
 match dscp af23
 match access-group name QoS-Silver
!
policy-map QoS-outbound
 class QoS-VoIP
  priority percent 20
  set dscp ef
 class QoS-Gold
  bandwidth percent 40
  set dscp af11
 class QoS-Silver
  bandwidth percent 20
  set dscp af21
 class QoS-Bronze
  bandwidth percent 10
  set dscp af31
policy-map Shape-QoS-Outbound
 class class-default
  shape average 800000
   service-policy QoS-outbound
!
zone security LAN
zone security WAN
zone security VPN
zone security DMZ
!
!
crypto isakmp policy 10
 encr aes 256
 authentication pre-share
 group 5
 lifetime 28800
crypto isakmp key jklEKJLFICkmkli389fd8(*dmfjiejsADSMS address 103.197.186.18  no-xauth
!
!
crypto ipsec transform-set transform-aes256-sha esp-aes 256 esp-sha-hmac
 mode tunnel
crypto ipsec transform-set transform-aes-sha esp-aes esp-sha-hmac
 mode tunnel
!
!
crypto ipsec profile profile-aes-sha-pfs5
 set transform-set transform-aes-sha
 set pfs group5
!
crypto ipsec profile profile-aes256-sha-pfs5
 set transform-set transform-aes256-sha
 set pfs group5
!
!
!
!
!
!
interface Tunnel0
 description --- Tunnel to Adelaide HQ ---
 ip address 172.16.222.2 255.255.255.248
 no ip redirects
 no ip proxy-arp
 ip tcp adjust-mss 1436
 tunnel source Dialer0
 tunnel mode ipsec ipv4
 tunnel destination 103.197.186.18
 tunnel protection ipsec profile profile-aes-sha-pfs5
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
 shutdown
 pvc 8/35
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface Ethernet0
 description ---Telstra VDSL---
 ip address dhcp
 ip nat outside
 ip virtual-reassembly in
!
interface FastEthernet0
 switchport voice vlan 110
 no ip address
!
interface FastEthernet1
 switchport voice vlan 110
 no ip address
!
interface FastEthernet2
 switchport voice vlan 110
 no ip address
!
interface FastEthernet3
 switchport voice vlan 110
 no ip address
!
interface Vlan1
 description LAN
 ip address 192.168.25.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface Vlan110
 description --- Shortel Voice VLAN ---
 ip address 10.110.3.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface Dialer0
 ip address negotiated
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip mtu 1460
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 ip tcp adjust-mss 1300
 shutdown
 dialer pool 1
 dialer idle-timeout 0
 dialer persistent
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname XXXXXXXXXXXXXXX
 ppp chap password 0 XXXXXXXX
 no cdp enable
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list nat interface Ethernet0 overload
ip route 0.0.0.0 0.0.0.0 Ethernet0
ip route 10.110.1.0 255.255.255.0 172.16.222.1
ip route 10.110.3.0 255.255.255.0 172.16.222.1
ip route 10.202.7.0 255.255.255.0 172.16.222.1
ip route 192.168.0.0 255.255.255.0 172.16.222.1
!
ip access-list standard vty-in
 permit 202.174.37.69
 permit 103.197.186.18
 permit 192.168.25.0 0.0.0.255
 permit 192.168.0.0 0.0.0.255
 permit 10.0.1.0 0.0.0.255
 permit 172.16.222.0 0.0.0.7
 deny   any log
!
ip access-list extended QoS-Bronze
 permit tcp any any eq www
 permit tcp any any eq 443
 permit tcp any any eq 22
 permit icmp any any
ip access-list extended QoS-Gold
 permit ip any host 192.168.0.6
 permit ip any 10.0.1.0 0.0.0.255
ip access-list extended QoS-Silver
 permit ip any host 192.168.0.250
ip access-list extended QoS-VoIP
 permit ip 10.110.3.0 0.0.0.255 any
ip access-list extended nat
 permit ip 192.168.25.0 0.0.0.255 any
 permit ip 10.110.3.0 0.0.0.255 any
!
dialer-list 1 protocol ip permit
!
!
control-plane
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
banner login ^C
***********************************************************************
*       Access to this System is limited to authorised users only.    *
*  Unauthorised users may be subject to prosecution under the Crimes  *
*                       Act or State legislation                      *
*     All Activity on this device is logged for Security purposes     *
*                                                                     *
*     Please note, ALL CUSTOMER DETAILS are confidential and must     *
*                         not be disclosed.                           *
***********************************************************************
^C
!
line con 0
 login local
 no modem enable
line aux 0
line vty 0 4
 access-class vty-in in
 login local

Telstra Smart Modem

Plug in and connect in minutes. Smart.

Find out more
Find out more about the Telstra 24x7 App ×
Manage your services and take advantage of offers while you’re out and about with the Telstra 24x7® App Find out more
Earn points on our new rewards program and enjoy tier benefits like discounted movie tickets and moreFind out more

Need a hand or want to share your expertise?
Register for CrowdSupport and get involved

Register now