CrowdSupport®
Regardz
Level 2: Rookie

Wireless doorbell no longer works after moving to Smart Modem Gen2

I recently moved to nbn and a new Telstra Smart Modem Gen2 (Technicolor DJA0231TLS).  Since then I have been unable to connect my previously working wireless doorbell (Mirabella / Anko / K-Mart WiFi Full HD Video Doorbell).  After much troubleshooting of the doorbell I replaced the Gen2 modem with the previous Technicolor DJN2130 and it works fine.  So the issue seems to be the Gen2 modem (or software version) rather than than the change to nbn.  The Gen2 modem is running software version Champagne (18.1.c), whereas the older modem is running version Aqua (16.3).  For now I will continue to use the older gateway.

Was this helpful?

  • Yes it was, thank you
  • No, I still need help
16 REPLIES 16
Level 24: Supreme Being
Level 24: Supreme Being

Re: Wireless doorbell no longer works after moving to Smart Modem Gen2

The doorbell probably only supports the 2.4 GHz WiFi band. There have been a few cases were the 2.4 GHz on the modem doesn't work and there is also a recent firmware up date (18.1c.443.950RA) that had a bug that turned 2.4 GHz WiFi off. The firmware version no is displayed on LHS of log in screen.

 

You can check if the 2.4 GHz WiFi band is working by disabling band steering in the modem's 2.4 GHz WiFi settings. When band steering is disabled -5G is added to the end of the 5GHz WiFi SSID. If you no longer see the modem's normal SSID in the list of available networks but only the normal SSID with -5G added the normal SSID is not working. If 2.4 GHz is not working contact Telstra and request a replacement modem.

 

The latest firmware version for the modem is 18.1c.443.950RB but this firmware update does not fix modems that have faulty 2.4 GHz due to previous update.

Regardz
Level 2: Rookie

Re: Wireless doorbell no longer works after moving to Smart Modem Gen2

Thanks for the prompt reply and advice !

I can confirm the gateway is running the latest (RB) firmware and the 2.4GHz radio is working.  I had previously disabled band steering and the 5GHz radio to ensure the doorbell was using the 2.4GHz band (as it does only support 2.4GHz). However that didn't resolve the problem.

Level 24: Supreme Being
Level 24: Supreme Being

Re: Wireless doorbell no longer works after moving to Smart Modem Gen2

You could try changing the modem's 2.4GHz WiFi channel. Also check the 2.4 GHz WiFi settings are the same as in the DJN2130 (Standard, Channel width, Security Mode etc).

 

Check if LAN IPv6 state is disabled on the DJN2130. If it is disable it on the DJA0231 (Advanced > Local Network). 

Level 14: Field Agent Mkrtich
Level 14: Field Agent

Re: Wireless doorbell no longer works after moving to Smart Modem Gen2

Hi - in case there is no resolution so far, with your troubleshooting, were you able to see the Technicolor Modem's 2.4 GHz SSID in your Genio App for connecting to and prior to a connection attempt, can you see the Mirabella Doorbell as a connected Wireless Device in the Home Screen with an IP Address in the Technicolor Modem. It should also show up in the Wireless Devices list as a 2.4 Ghz link with its speed of Wi-Fi connection?

 

If the App has no ability to reset the doorbell, did you also try removing the two batteries, waiting 60 seconds and then re-inserting them to effect a reset of the Doorbell and then try to connect it through the Genio App as a new Wi-Fi Network? Maybe the Doorbell is capable of only having one set of modem credentials at a time.  

Regardz
Level 2: Rookie

Re: Wireless doorbell no longer works after moving to Smart Modem Gen2

Hi cf4,

WiFi channel was different.  Changed to Ch6 to match old gateway, doorbell still won't connect.  Also tried the following settings which were different, still no joy. (Short guard interval disabled, cyclic diversity on (was auto on new gw). Otherwise all wifi settings identical.

IPv6 disabled in both gateways, no change. Doorbell still won't connect via new gateway

Regardz
Level 2: Rookie

Re: Wireless doorbell no longer works after moving to Smart Modem Gen2

Hi Mkrtich,

The Genio app doesn't seem to complain about the SSID and steps on to showing the QR code for the doorbell.  The doorbell beeps in response to showing the QR code to its camera, but then does not connect (keeps blinking red, and app connection times out).  To prove the theory of remembered credentials, I tried the full power reset by removing the batteries. I also changed the SSID & PW in the old gateway, removed the device from the Genio app, reset the doorbell, and it connects within 10-15 seconds.  Going back to the new gateway it will not connect (even using the identical SSID/PW). So I am still suspecting a gateway/firmware issue.

Level 24: Supreme Being
Level 24: Supreme Being

Re: Wireless doorbell no longer works after moving to Smart Modem Gen2

Try changing both IPv6 and IPv4 DNS server in Advanced > Local Network. Changing DNS server settings has fixed some connection and might fix your connection problem.

Level 14: Field Agent Mkrtich
Level 14: Field Agent

Re: Wireless doorbell no longer works after moving to Smart Modem Gen2

Thank you for the feedback, most puzzling and tending to agree with your diagnosis.

 

If the doorbell beeps in response to the QR code, there must be a signal from your Wi-Fi enabled phone to the DJA0231 which then goes to the camera before it gets rejected. It appears when the App fires up, there is something blocking the allocation of the camera's IP address from the Gen 2 Modem. It may indicate a possible a DJA0231 TLS Firewall setting or malfunction preventing the connection which is unexpected as I understand the DJA0231 supports NAT Loopback and you have the latest firmware.

 

If you haven't done so to date, suggest you report this formally to Telstra as a fault so that it can be addressed by a possible complimentary Platinum Support process or in a future firmware update. 

Regardz
Level 2: Rookie

Re: Wireless doorbell no longer works after moving to Smart Modem Gen2

ok, good idea as I was using a different (non-Telstra) DNS on the old gateway. But have now tried Telstra, Google and OpenDNS on the new gateway still no joy with the doorbell connection. It is not showing up in the list of connected wifi devices (if DNS was the issue I would still have expected it to show as an active wifi connection even if the registration could not be completed)

Level 24: Supreme Being
Level 24: Supreme Being

Re: Wireless doorbell no longer works after moving to Smart Modem Gen2

Have you tried changing WiFi security mode to WPA+WPA2 PSK?

Regardz
Level 2: Rookie

Re: Wireless doorbell no longer works after moving to Smart Modem Gen2

Yes have now tried that, no change. Old modem is set to WPA2 PSK

Regardz
Level 2: Rookie

Re: Wireless doorbell no longer works after moving to Smart Modem Gen2

Thanks. I will report a formal fault, just thought I'd start here in case people had heard of similar issues. There were a couple of comments on productreview.com.au which seem to indicate connection problems but not much detail.  I would be interested to know if anyone has the doorbell working successfully with this new modem.

Kerborous
Level 4: Private Eye

Re: Wireless doorbell no longer works after moving to Smart Modem Gen2

Hi Regardz,

 

May I make a suggestion of looking the following steps of Connectivity between various devices and the Technicolor DJA0231TLS gateway.

 

Q1: During the registration process can you confirm that the smart phone that runs the Mirabella APP has access to the modem by browsing to the gateway's IP address 192.168.0.1.  You should see a GUI login page of the modem.

 

Q2: After the camera scans the QR code from the Mirabelle APP the camera ingests the WiFi credentials which are particular to your GW that were entered as part of the install process outlined in the youtube https://www.youtube.com/watch?v=4NGksvTyoBU link. Please login into the modem's GUI page via a browser to 192.168.0.1 (admin / Telstra) and confirm if the Mirabelle device appears in the GUI of the modem? It may appear as a MAC address or have a user friendly name under the WiFi devices map of the GUI.

 

Answers to Q1 and Q2 will establish if there is IP connectivity between the devices and hopefully give us a clue to the problem. 

Regardz
Level 2: Rookie

Re: Wireless doorbell no longer works after moving to Smart Modem Gen2

Hi Kerborous,

Sorry for some reason Crowdsupport wouldn't let me reply yesterday.  There is no IP connectivity between the devices when running the latest gateway firmware.  The device does not show up in the list of devices on the gateway, indicating there is some issue in establishing the wifi connection.  With the same gateway running an earlier version of firmware the doorbell connects, so this would appear to be a firmware related issue. The Telstra devices team is now working on this issue with the device vendor.

Kerborous
Level 4: Private Eye

Re: Wireless doorbell no longer works after moving to Smart Modem Gen2

So just clarifying that neither the Smart phone nor the Mirabelle door bell had IP connectivity with the DJA0231 latest GW firmware?

Highlighted
Regardz
Level 2: Rookie

Re: Wireless doorbell no longer works after moving to Smart Modem Gen2

The Smart phone does, but the doorbell does not.  The gateway maintains a historical list of connected devices and it has never seen the doorbell (the hostname is 'DEFAULT' when it does connect on the earlier firmware and older DJN2130 gateway)

Telstra Smart Modem

Plug in and connect in minutes. Smart.

Find out more
Find out more about direct debit and the Telstra 24x7 App ×

Avoid queueing up and never worry about late fees againSet up direct debit
Manage your services and take advantage of offers while you’re out and about with the Telstra 24x7® App Find out more

Need a hand or want to share your expertise?
Register for CrowdSupport and get involved

Register now