Highlighted
Level 1: Cadet

No service, but connected.

I keep having a weird problem where I have no service, yet I have bars up the top. I will go to send a message or make a call and it says I can't. Same with the Internet. I'll go to search and the page never loads. People will try to ring me and it will go to message bank. Text messages never arrive. It's as if I am disconnected yet it says I have a few bars.

This is mostly an intermittent problem. I'll go for weeks without an issue then it will just happen. Here are the interesting facts.

Turing the phone off and on fixes it. Soon as I do that all the missed messages and calls come in.

Switching aeroplane mode on and off does not fix it, but instead of having bars at the top it will now say searching and no service (which is the reality of the matter, not the fake bars at the top)

If the phone is left for long enough, it will suddenly get all these missed messages and calls. Sometime a day after they were made.

A clue that the bars at the top are fake is that it will say 3g instead of 4g. Once the phone is turned off and on it goes back to 4g.

This issue happens from time to time, but it has happened every single time Telstra have rung me. I have rung customer service, accepted to be rung back, and they have rung back within 15 minutes only for it to go to message bank. Telstra ringing the phone seems to trigger this connection problem (but it does happen by itself.)

This started a year ago on a iPhone 4s. I assumed the phone was the problem as it was old and still running a very old iOS. I got a 5s 6 months ago... The exact same issue is happening (except for the 3G/4g switch as the 4s was only 3G). This leads to think it is not the phone(s) that are the problem, because it would be an amazing coincidence for two iPhones with two very different iOS installed to have the exact same issue.

Was this helpful?

  • Yes it was, thank you
  • No, I still need help
2 REPLIES 2
Highlighted
Level 1: Cadet

Re: No service, but connected.

I've started having this problem but with a HTC One M8.  Symptoms are the same as described by Jazzamc

Highlighted
Telstra (Retired)
Telstra (Retired)

Re: No service, but connected.

Hi Jazzamc & bwilson

best will be to contact our mobile faults team, 132200 and say "mobile faults", to have these issues with your mobiles checked out by our team.
-Ern

Need help? Check out our Community Wiki or Support Portal || Looking for a new mobile? Order online today || Get help with any Tech at Home with Telstra Platinum || Don't forget to tag answers as Accepted Solutions and give a Like to the member(s) who helped you out.

All moderation actions are supported by the CrowdSupport Community Guidelines

Set it & forget it

With direct debit there’s no need to give paying your bill another thought.

Avoid queuing up and never worry about late fees again.

Setup direct debit