Level 1: Cadet

Telstra Speedtest https://speedtest.telstra.com/ not working 404 error

Have tried to run https://speedtest.telstra.com/  and it fails with a 404 error as can be seen in the captures.

This worked previously and is powered by OOKLA.

The page does open but one can no longer run the speed test from there.What has changed and why were we not informed ???

Strangely enough the direct link to https://speedtest.telstra.com/ no longer functions  as it produces the ERROR 404.

  • If Telstra has stopped using this link why is it still accessible and not removed ???

( Is this now the https://speedtest.net link powered by OOKLA )

  • If so why were we not informed of this ???



  • Has the Below taken over from the Telstra Link in regards to running speed test ???

Was this helpful?

  • Yes it was, thank you
  • No, I still need help
Level 23: Superhero

Re: Telstra Speedtest https://speedtest.telstra.com/ not working 404 error

I'm pretty sure I know the reason.

Telstra and others have to pay Ookla to use the speedtest.

I can recall years ago, every year just before the year's payment was becoming due, there is a message on Ookla rebranded web speedtests that the yearly payment is becoming due.

I do recall that on more than one occasion I wrote to Telstra that there the year re-subscription is becoming due, and that's why I think it's not presently enabled.

If I have helped you, a "Like" would be appreciated.

If my advice is a solution, please acknowledge it.

I'm not a Telstra employee.
50 + years exp. in radio comms., eg mobile phones since 1963, two-way radios, base stations, antennas & pagers. Expert in current Telstra Go repeaters & smart antennas.
"Being 75 years of age, entitles one to be an expert at everything!!"

Set it & forget it

With direct debit there’s no need to give paying your bill another thought.

Avoid queuing up and never worry about late fees again.

Setup direct debit