Level 1: Cadet

Bigpond cable (not NBN) online Usage meter not working

I want to check my usage to see how much I am using so I can better understand how much more internet I'm using now working from home compared to before. I can login to the www.my.telstra.com.au/myaccount portal and see my services and mobiles. When I select the Internet service and then select usage I get the error in the image below. No data visible for the last few months. I tried calling and was on hold and hung up, I tried the chatbots which were useless and now am trying crowd support. How can I get my usage data for home internet working again

Was this helpful?

  • Yes it was, thank you
  • No, I still need help
Level 1: Cadet

Re: Bigpond cable (not NBN) online Usage meter not working

I have the same problem, can it be fixed please ?.

Set it & forget it

With direct debit there’s no need to give paying your bill another thought.

Avoid queuing up and never worry about late fees again.

Setup direct debit