CrowdSupport®
Highlighted
Level 1: Cadet

Can't get Plex or Kodi to work with my Telstra Gateway Connection kit

I can not for the life of me figure out how to get plex or kodi to work with my Telstra Gateway kit. It works fine when my server is connected to a different network however. And both Plex and Kodi appear to be able to see my media server - I can browse the library and attempt to load a video, but as soon as I try to play it it just hangs forever, or tells me of an unspecified error and to restart the server and app. Any suggestions?

Was this helpful?

  • Yes it was, thank you
  • No, I still need help
4 REPLIES 4
Highlighted
Level 22: Superhuman
Level 22: Superhuman

Re: Can't get Plex or Kodi to work with my Telstra Gateway Connection kit


@limimi wrote:

I can not for the life of me figure out how to get plex or kodi to work with my Telstra Gateway kit. It works fine when my server is connected to a different network however. And both Plex and Kodi appear to be able to see my media server - I can browse the library and attempt to load a video, but as soon as I try to play it it just hangs forever, or tells me of an unspecified error and to restart the server and app. Any suggestions?


@limimi Have you enabled File Server and DLNA in the modem Content Sharing section?

 

 

I use Plex allot, but haven't tried a hard-drive in the modem yet for it. I'll try that tomorrow.

 

I'll ping one of our modem guru's who might know what the issue is @cf4 

Someone keeps putting vegetables in my beer crisper
Highlighted
Level 24: Supreme Being
Level 24: Supreme Being

Re: Can't get Plex or Kodi to work with my Telstra Gateway Connection kit

Which model modem do you have and what is its firmware version? The modem model and Firmware version is displayed on left hand side of modem's login page.

Highlighted
Level 1: Cadet

Re: Can't get Plex or Kodi to work with my Telstra Gateway Connection kit

@Ozmoz I do have file sharing and dlna enabled, also my wording was a little confusing - I have a server pc with my media on it, not a hard drive.

 


@cf4 wrote:

Which model modem do you have and what is its firmware version? The modem model and Firmware version is displayed on left hand side of modem's login page.


There doesn't appear to be any information on the left hand side of the login page, but according to gateway settings my hardware version is FAST5355-A and my software version is SG7E10001332, does tthat help?

Level 24: Supreme Being
Level 24: Supreme Being

Re: Can't get Plex or Kodi to work with my Telstra Gateway Connection kit

I thought you might have had one of the Gen 2 modems. Never seen this problem before with the F@st5355 modem. One thing you could try is turning off LAN IPv6. Its been a long time since I used that modem but I think the setting is located in Advanced Internet.

 

If that doesn't work you could use other router as the main router and if you have NBN use Telstra gateway as a VOIP ATA connected to LAN port of other router.

Set it & forget it

With direct debit there’s no need to give paying your bill another thought.

Avoid queuing up and never worry about late fees again.

Setup direct debit