GW15
Level 1: Cadet

Devices connecting to home WIFI but no internet

Can anyone help?

We are having an issue with our home WIFI network, where devices such as phones, and a tablet can 'connect' to the router, but an error occurs saying that the "Internet may not be available" or "Waiting until internet connection improves" - meaning the internet does not work. This has occurred for a few weeks, any the devices are just burning through mobile data. 

Laptops can connect to the network without problem, and the internet usually works through WIFI on the laptops..

Prior to this, there wasn't an issue with the devices connecting at all.

The modem is a Telstra Smart Modem DJA0230.

The devices are all runing Android. A Samsung Note9 phone (Android 9), and Blackberry Key2 (android marshmellow) phone.

I spent 45 mins on the phone to Telstra who ran through restarts of the devices, and a hard reset of the modem without success, and ultimately decided that the devices had simultanously failed in some way and that I should contact the manufacturers. 

To me it seems like maybe there is some issue with the settings or the connection that has changed. I have tried changing security mode from WPA2 PSK to WPA+WPA2 PSK as suggested on another forum, to no avail.

I confess to not being an expert in this area...

Was this helpful?

  • Yes it was, thank you
  • No, I still need help
7 REPLIES 7
Mkrtich
Level 21: Augmented
Level 21: Augmented

Re: Devices connecting to home WIFI but no internet

Hi - do you only get these errors when you use the web browser in your device i.e. can you access the Google Play Store or Maps via Wi-Fi? If you are using Chrome for web browsing, have you cleared out the Data Cache and History in its Settings. If you can access the Google Play Store and web browsing still errors after clearing cache, maybe delete Chrome and then reload it to see if any improvement occurs. 

 

Has the DJA0230 firmware been upgraded recently - the version will be on the Home screen. 

cf4
Level 25: The Singularity
Level 25: The Singularity

Re: Devices connecting to home WIFI but no internet

There are a couple of things you could try.

  1. Disable band steering by removing the tick next to band steering in the modem’s 2.4 GHz WiFi settings. This results in -5G being added to end of the 5GHz WiFi SSID. By default both WiFi bands share the same SSID and some devices have trouble connecting when both SSIDs are the same.
  2. By pass Telstra broadband protect by changing DNS server for both IPv4 and IPv6. There is a drop down list of DNS servers in the modem at Advanced > Local Network.

After making changes in modem forget WiFi network on device and then reconnect.

GW15
Level 1: Cadet

Re: Devices connecting to home WIFI but no internet

Ok interesting.

I cleared the google chrome cache. 

The firmware version is 18.1.c.0443-950-RA - I'm not sure if there's been a recent update.

I inactivated IPv6. For IPv4, I changed the primary DNS to Google (8.8.8.8), and forgot the network and reconnected - and it worked! The internet is now working exclusively via wifi without the above error - so that's great.

But I assume it is preferred / I should be able to use the Telstra IPv4 primary DNS setting? Do you know how I can remedy this?

cf4
Level 25: The Singularity
Level 25: The Singularity

Re: Devices connecting to home WIFI but no internet

The only way to have this fixed is to lodge a fault. You will probably be referred to platinum support who charge a fee for service but because the problem is Telstra Broadband protect blocking a site it shouldn't block the fee should be waived. Broadband protect is probably blocking the site used by android devices to check successful internet connection.

A lot off people use a non Telstra DNS to avoid being blocked from sites that Telstra blocks. There are certain sites that should be blocked but these sites are also blocked by reputable DNS servers such as Google.

The only disadvantage in using a non Telstra DNS is that the Telstra online parental controls are also bypassed.

Evo8877
Level 1: Cadet

Re: Devices connecting to home WIFI but no internet

I am currently having the same issue. Telstra platnium team cant seem to find a solution. Im on the verge of trying another service provider.

Anna2020
Level 2: Rookie

Re: Devices connecting to home WIFI but no internet

Good idea

Teltra team is all banana

They have no experience

They will not help you

You should move to another provider

Evo8877
Level 1: Cadet

Re: Devices connecting to home WIFI but no internet

Gw15 has your issue been resolved yet

Set it & forget it

With direct debit there’s no need to give paying your bill another thought.

Avoid queuing up and never worry about late fees again.

Setup direct debit