Highlighted
Level 2: Rookie

Telstra 5G Wifi Pro Modem external antennas not working

Hi There, I recently purchased the Telstra 5g Wifi Pro which works great but the only issue I have is that the device doesn't recognize when external antennas are connected. I'm not sure if it's a firmware issue or faulty device. Any info would be greatly appreciated. Thanks

Was this helpful?

  • Yes it was, thank you
  • No, I still need help
11 REPLIES 11
Highlighted
Level 21: Augmented

Re: Telstra 5G Wifi Pro Modem external antennas not working

Does the antenna you are attaching have TS9 connectors? have a good close look at them in case they are damaged? If you are just using one, attach it to Port 1, but for best results you need a dual connector MIMO antenna. MIMO antennas might need to be 'pointed' for best signal and the two leads are usually relate to the phased angle the antenna arms are positioned at -if signal is low, swap the leads and see if that improves it. Also, there are some antennas on the market with outlandish gain figures so check those and also the bands the antenna is tuned for.

 

I don't believe there are any setting in the interface, related to the 4G antennas.

Stevo 52
Too many devices, probably an addict :-) also a tinkerer and developer of stuff..
Not with Telstra, just another customer like you!
Highlighted
Level 2: Rookie

Re: Telstra 5G Wifi Pro Modem external antennas not working

Hi SteveW_52,

 

Thanks for your response, yes I have TS9 connectors and they are in good working order. I have a MIMO antenna on my roof directed with line of sight at my local tower. My antenna is a RF wide band MIMO 700-3800mhz with 2 patch leads. I also have low loss LCU 400 Low loss cables connected, I have been using this setup on a different modem and get great results. I dont think my antenna is the issue as I have been trying like you said with different configurations. I have gone through the interface as well, not a mention of external antennas but a online copy of the devices manual mentions the external antennas. Not sure what to think? thats why I mentioned the firmware on the device. Regards 

Highlighted
Level 21: Augmented

Re: Telstra 5G Wifi Pro Modem external antennas not working

The documentation probably just referred to the ports being available. It could be just marginal signal difference being sensed by the modem (which would have to auto switch the antenna). Sounds like you have got a decent antenna set up. The only thing that you might need to check is the bands available on the tower you use, and the bands used by the modem.

Stevo 52
Too many devices, probably an addict :-) also a tinkerer and developer of stuff..
Not with Telstra, just another customer like you!
Highlighted
Level 2: Rookie

Re: Telstra 5G Wifi Pro Modem external antennas not working

Thanks again for your response SteveW_52,

My tower is all good with the bands. The Wifi 5g Pro uses the usual 4gx bands , 3g bands and the new 5g also. I have in the past used both Telstra and Optus sims in the Nighthawk M1 ,M2 with no problems  and currently using a unlocked Huawei B818. This new one has me got me stumped at the moment. Cheers 

Highlighted
Level 21: Augmented

Re: Telstra 5G Wifi Pro Modem external antennas not working

I have seen a few posts about issues with that model..  it might be due for a firmware update soon?

Stevo 52
Too many devices, probably an addict :-) also a tinkerer and developer of stuff..
Not with Telstra, just another customer like you!
Highlighted
Level 2: Rookie

Re: Telstra 5G Wifi Pro Modem external antennas not working

Awesome, Fingers crossed.

Thanks for your assistance.

Highlighted
Level 21: Augmented
Level 21: Augmented

Re: Telstra 5G Wifi Pro Modem external antennas not working

Hi - Some posts on Whirlpool say the External Antennae works for them and other posts say they don't. There is no screen showing for configuring them in the User Guide as in other mobile broadband modems, which is unusual unless they are Default Auto ON. One of the posts indicated his unit did one firmware update from original and maybe that is the key as stated by @SteveW_52  above.

 

A web search on the Telstra Firmware Version of the MU500 showed its initial Release to be  TELSTRA_AU_MU500V1.0.0.B24.EF dated 28-05-2020. If you have purchased yours recently, one would expect it have done an Auto Firmware Update by now but you may have to activate a setting for this to automatically occur? Sometimes ZTE User Manual instructions don't apply to Telstra versions. 

Highlighted
Level 2: Rookie

Re: Telstra 5G Wifi Pro Modem external antennas not working

Thanks for your reply Mkrtich,

The device did that update which you mentioned when I powered it up initally no problems. I have the auto updates all set to auto and have tried checking for further updates but it indicates it is on the most current firmware. Guess I'll have to wait for the next firmware update at this stage. Cheers

Highlighted
Level 1: Cadet

Re: Telstra 5G Wifi Pro Modem external antennas not working

I have the same Telstra unit and the same problem.  I also have a roof mounted MIMO antenna pointing to the local tower that worked well with 4G.  Doesn’t seem to make any difference with 5G however. Frustrating 

Highlighted
Level 21: Augmented

Re: Telstra 5G Wifi Pro Modem external antennas not working

If you lock the modem to 4G channels, does the antenna make a difference?

 

5G seems a bit of a murky area, the Pixel 5's have 5G apability but that is not available in dual SIM mode (eSIM and uSIM), which I am guessing is something to do with antenna switching/sharing.

 

Maybe those 5G modems are like that, with the external ports disabled for 5G? but available for 4G..  just a thought.

Stevo 52
Too many devices, probably an addict :-) also a tinkerer and developer of stuff..
Not with Telstra, just another customer like you!
Highlighted
Level 2: Rookie

Re: Telstra 5G Wifi Pro Modem external antennas not working

G'day SteveW_52,

I have tried all external configurations 5g, 4g, and 3g.

They don't register when connected at all.

I have heard that a new firmware update is coming in early November.

Can only hope that this fixes the external antenna connections in this device 

Set it & forget it

With direct debit there’s no need to give paying your bill another thought.

Avoid queuing up and never worry about late fees again.

Setup direct debit