Highlighted
Level 1: Cadet

Trying to make Chromecast work with Technicolor TG797n v3

Answered

I brought my Chromecast over from the U.S., where I had no trouble using it with my Windows laptop and my Android phone. I hooked it up to my new TV over here yesterday and seem to be hitting a roadblock.

 

I can see the chromecast and it can see my router. I entered the password on my phone and was able to set it up. When I choose the correct input source, I see it on my TV and it says it's ready to go.

 

However, when I try to enter the network password in the app on my laptop, it says it can't save setting to chromecast  It says if I have a dual band router to make sure it's not in AP isolation mode, and that my router needs to have a MAC whitelisting.   But it works from my phone OK.  It seems to knock the laptop offline everytime I try to connect too.

 

I can cast YouTube from my phone, so the router has to be working, right? I've entered the password about 10 times into my pc and it still wont' take it.  

 

Thanks for any advice.

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Level 20: Director
Accepted Solution

Re: Trying to make Chromecast work with Technicolor TG797n v3

Hello there,

 

Looking at the Chromecast website setup page it lists.

 

- Have you tried Chrome browser. ?

- Try powering off your modem for 2 mins by unpluging your power at the back of the modem.

- Try disabling your anti vuris to test a connection.

- Link below to help you get started if need be.

 

See how you go with this, let us know how you get along.

 

Please visit www.google.com/chromecast/setup in your Chrome browser

 

 

Cheers.

View solution in original post

Was this helpful?

  • Yes it was, thank you
  • No, I still need help
3 REPLIES 3
Highlighted
Level 20: Director
Accepted Solution

Re: Trying to make Chromecast work with Technicolor TG797n v3

Hello there,

 

Looking at the Chromecast website setup page it lists.

 

- Have you tried Chrome browser. ?

- Try powering off your modem for 2 mins by unpluging your power at the back of the modem.

- Try disabling your anti vuris to test a connection.

- Link below to help you get started if need be.

 

See how you go with this, let us know how you get along.

 

Please visit www.google.com/chromecast/setup in your Chrome browser

 

 

Cheers.

View solution in original post

Highlighted
Level 23: Superhero

Re: Trying to make Chromecast work with Technicolor TG797n v3

Hi Chris, I too have a Chromecast, great device.

 

As you bought this in the US, you might find to get through the barriers you might need to do a factory reset to our region. They can be region sensitive. I know one user who bought one in the UK, had similar problems to you, seemed OK, but hit the wall, did a reset for Oz and was up and running.

 

Sig 2

If I have provided an answer, or posed a question that helps or interests you, your KUDOS vote would be appreciated Image and video hosting by TinyPic
If I or anyone has provided a solution, you'll help others if you mark our answer as the Solution The Ghoust Writers: STUDYING ABROAD


NB: I am NOT a Telstra employee, just another customer like you.
Highlighted
Level 1: Cadet

Re: Trying to make Chromecast work with Technicolor TG797n v3

Actually it was my pop up blocker. I entered in chromecast.com as a site not to block and now I'm on but it's very very slow.  I'm using U.S. Netflix (so my son in college back home and use it too) and an unblocker to bring it to my computer, then chromecast to cast it to my tv. May be just too many things going on between origin of show and where it displays. But at least Chromecast now works for me. Thanks!!

Telstra Smart Modem

Plug in and connect in minutes. Smart.

Find out more