jaizels
Level 3: Gumshoe

Oops something went

So this is now my second thread. Multiple times on 24x7 chat and on phone. Since changing plans earlier this year everytime I check my data usage in the app or on the web it says something went wrong. My partners device displays fine but not mine. They are both on the same account. The last woman I spoke to assured me that it's not anything Telstra can do at their end and only crowd support can fix it.

Was this helpful?

  • Yes it was, thank you
  • No, I still need help
5 REPLIES 5
Smiley3
Level 23: Superhero
Level 23: Superhero

Re: Oops something went

Hi jaizels,

 

Crowdsupport is a community forum where it's mainly customer's helping other customer's....no-one on here (including Telstra Support Employees) have access to customer's Accounts. 

 

It makes me laugh when I read that a customer has been advised by a Telstra Employee to go on Crowdsupport for a fix.

 

Your problem is clearly at Telstra's end due to the fact that you get the message "something went wrong" when you look at your service on the website.

 

I'd advise you to put in a complaint to Telstra.

The below link is to lodge a complaint online. You'll get a Case Manager who will look into the problem. It will take longer than usual to get a Case Manager due to a  shortage of staff during COVID-19.

https://say.telstra.com.au/customer/general/forms/Email-Complaint

 

The below link has other methods that you can use to lodge a complaint. 

https://www.telstra.com.au/contact-us/feedback-complaints/make-a-complaint

 

If you can't get it fixed through your Case Manager then the next step would be to contact the TIO.

You first need to go through the Telstra Complaints team before you contact the TIO.

 

 

 

I am NOT a Telstra employee and never have been. However, I AM a customer who volunteer's my time in the hope to help someone with their question.
To show your appreciation to myself or another member, please click on the LIKE or mark as a SOLUTION for any post that you have found helpful on this forum.
TommyR
Support Team
Support Team

Re: Oops something went

Hi Jaizels, 

Are you still getting an error when logging into your My Telstra App? Can you please delete the app off your phone completely and then re-download from your app store, install the new version and then see if you still have the same troubles with keeping logged in. 
 

If that does not work for you, please lodge a fault with our My Telstra App/My Account support team here https://tel.st/uj325. They will follow up with you so we can get this working again. 


Let me know how you go. 


Regards - 
 

____________________

Need help? Check out our Community Wiki or Support Portal || Looking for a new mobile? Order online today
Don't forget to tag answers as Accepted Solutions and give a Kudo to the member(s) who helped you out

All moderation actions are supported by the CrowdSupport Community Guidelines

jaizels
Level 3: Gumshoe

Re: Oops something went

Mate, I have a new phone and it's doing the same, I do it from my partners phone it's the same, through the web page that Telstra hosts is doing the same. I'm not sure how uninstalling and reinstalling will fix an error that is clearly server related.

jaizels
Level 3: Gumshoe

Re: Oops something went

I totally agree. Classic Telstra giving the run around. 

jaizels
Level 3: Gumshoe

Re: Oops something went

So for all you people playing at home, finally solved the issue. Would recommend to anyone else having the same issue. I have now signed over to a different telco. After 20 years of using Telstra as a provider, am finally moving on. I have found after all these years you get more support out of a push up bra than their tech support. Peace out ! 

Set it & forget it

With direct debit there’s no need to give paying your bill another thought.

Avoid queuing up and never worry about late fees again.

Setup direct debit