Level 1: Cadet

Telstra ID and new Prepaid

I have been going around in circles for a week and a half trying to set up the My Telstra App to manage the prepaid and at least set up an auto recharge. I tried to set up a Telstra ID, and it said that I already had one (maybe from when I ordered the SIM). I couldn't remember the password so I successfully reset it.


If I log on using the App (on both Android and IOS)  I get the message "We can't display your account. There was an issue displaying your account please wait a few minutes before signing in again". I've been trying that for a week and a half.


If I log in on a browser I get a message saying "No accounts found", but an click on the "Settings Personal" and see my ID details (so I a successfully logged in). If I click on Account Services I get an error message "404 - Page not found". I've tried it on Chrome, Safari, Firefox, Edge and even Internet Explorer with the same result.

I've tried to chat with Telstra online but they say I have to do it in the My Telstra App.

I have tried chatting in the My Telstra App, but if the phone goes to sleep, while waiting for replies, you lose the whole session.


Does anybody have any suggestions as to what I can do?

Was this helpful?

  • Yes it was, thank you
  • No, I still need help
Level 25: The Singularity
Level 25: The Singularity

Re: Telstra ID and new Prepaid

You shouldn't lose the session in the My Telstra app if your phone goes to sleep. Unfortunately, at the moment it is also the only way to solve your problem as it would indicate that there is something wrong with your Telstra ID that isn't allowing proper access.

Never be afraid to back yourself when trying new things, just always make sure you have 3 escape routes if things go wrong.
Level 1: Cadet

Re: Telstra ID and new Prepaid

Thanks, I suspect that there is a problem with the account but not sure how to get it fixed, because I can't get on to anybody who will give any answer.


In one chat (app on iphone) they sent me the account number and said you need to create an ID, with a link. I clicked on the link and went around in circles with the "the ID already exists you can log in". By the the time I tried to go back to the chat the message string and account number was gone. The ID that I am using is the one I am working on right here.


Eventually I tried the "Telstra chat" and kept that alive for a couple of hours. Did all the ID stuff & described the problem. I did get a message saying that "there is an ongoing problem with the online platform" From what I can see in CrowdChat that has been going on since at least 2016, but people have a least been able to get onto support.


After another big wait Got the message "I apologize for the delay on the responses as we are assiting multiple customers at a time. I will be checking up with my support, please bear with me". That was the last I heard and it went back to asking "what can we help you with?" and you go back to the start.

Set it & forget it

With direct debit there’s no need to give paying your bill another thought.

Avoid queuing up and never worry about late fees again.

Setup direct debit