paulhaz
Level 2: Rookie

10 Play on Telstra TV

I am unable to load the 10 Play app on my Telstra TV model 4701TL version 10.0.3 6071

The 10 Play app version is version 5.1.2 released September 2020.
I have contacted channel 10 and they have advised i need to download version 6.5.0
I have uninstalled the 10 play app and then re-install but it continues to re-install version 5.1.2
I cannot see any other version.

Channel 10 have advised that version 5.1.2 is no longer supported and therefore will not run.

How can I get version 6.5.0 on my Telstra TV.

Was this helpful?

  • Yes it was, thank you
  • No, I still need help
18 REPLIES 18
Jupiter
Level 25: The Singularity
Level 25: The Singularity

Re: 10 Play on Telstra TV

The 6.5.0 version should be the one that installs. I've just check my Telstra TV (same model as yours) and it's working correctly.

Never be afraid to back yourself when trying new things, just always make sure you have 3 escape routes if things go wrong.
SteveW_52
Level 22: Superhuman
Level 22: Superhuman

Re: 10 Play on Telstra TV

You could try doing a full system up date Settings | System |Sytem Update - which should check/update the system firmware and all apps...

 

My TTV3 is OK too, the 10 app is 6.5.0

Stevo 52
Too many devices, probably an addict 🙂 also a tinkerer and developer of stuff..
Not with Telstra, just another customer like you!
Jupiter
Level 25: The Singularity
Level 25: The Singularity

Re: 10 Play on Telstra TV

If you do the system update that @SteveW_52 suggests; after the system update but before you reinstall the 10 play app, unplug the power from the Telstra TV, wait 30 seconds and plug it back in. That should let it start without any remnant code still running.

 

The only option after that is a full factory reset.

Never be afraid to back yourself when trying new things, just always make sure you have 3 escape routes if things go wrong.
paulhaz
Level 2: Rookie

Re: 10 Play on Telstra TV

Thanks for the suggestions.
I have done a software update, however it said already up to date.

Then I did a factory reset and set everything up again.

Still after doing software update and factory reset, the 10 play app is still version 5.1.2

So I am unable to get the new version. So I am back to the start again.

RokuMalcolm
Technology Specialist
Technology Specialist

Re: 10 Play on Telstra TV

I'm looking into this.

Senior Software Engineer at Roku.
The opinions expressed on this site are my own and not the official views of Roku or Telstra.
RokuMalcolm
Technology Specialist
Technology Specialist

Re: 10 Play on Telstra TV

5.1.2 is the correct version.

What happens when you try to load the app?

Senior Software Engineer at Roku.
The opinions expressed on this site are my own and not the official views of Roku or Telstra.
paulhaz
Level 2: Rookie

Re: 10 Play on Telstra TV

RokuMalcolm
Technology Specialist
Technology Specialist

Re: 10 Play on Telstra TV

Looking at the source of the app, this error does indicate a network issue, it's not a catch-all error.

Are you able to stream ok with other apps?

What does the "Check connection" option in the network settings report?

Senior Software Engineer at Roku.
The opinions expressed on this site are my own and not the official views of Roku or Telstra.
paulhaz
Level 2: Rookie

Re: 10 Play on Telstra TV

Every other app works perfectly. I can stream 9now, 7plus, netflix etc but not 10 play.

I have a support ticket with channel 10 and they advised must update to version 6.5.0

RokuMalcolm
Technology Specialist
Technology Specialist

Re: 10 Play on Telstra TV

Channel 10 have entered a different version number into the Telstra App Store backend to their internal version number. You do have 6.5.0.

 

Senior Software Engineer at Roku.
The opinions expressed on this site are my own and not the official views of Roku or Telstra.
Ozmoz
Level 22: Superhuman
Level 22: Superhuman

Re: 10 Play on Telstra TV

I don't mean to hijack this thread, but I'm just wondering what is the difference between the Telstra TV3 4700TL and 4701TL?

My body's absorbed so much hand sanitizer that when I pee, it cleans the toilet. 🙂

Footnote: I dont work for Telstra, I just try to help out fellow Telstra customers.
RokuMalcolm
Technology Specialist
Technology Specialist

Re: 10 Play on Telstra TV

TTV3 (4701TL) is smaller than TTV2 (4700TL).

They use the same firmware image, so any hardware differences are minimal.

Senior Software Engineer at Roku.
The opinions expressed on this site are my own and not the official views of Roku or Telstra.
paulhaz
Level 2: Rookie

Re: 10 Play on Telstra TV

 I have a connection but still 10 play will not load

Ozmoz
Level 22: Superhuman
Level 22: Superhuman

Re: 10 Play on Telstra TV

Hi @paulhaz 

 

Generally, most issues we see on Crowd Support and the TTV is due to the Telstra modem over WiFi, so I am assuming your using the same setup.

 

If you are, I suggest a modem reboot, and if possible after that, use an Ethernet connection for testing.

 

Thanks @RokuMalcolm . I thought the 4700TL was a TTV3 also.I need to compare the pair (Aussie TV advert, sorry).

My body's absorbed so much hand sanitizer that when I pee, it cleans the toilet. 🙂

Footnote: I dont work for Telstra, I just try to help out fellow Telstra customers.
paulhaz
Level 2: Rookie

Re: 10 Play on Telstra TV

Every other app works perfectly.  Only 10 play will not load.

Channel 10 say I need version 6.5.0 which I cannot get.

paulhaz
Level 2: Rookie

Re: 10 Play on Telstra TV

I have tried a weird ethernet connection and still 10 play will not load. Every other app loads perfectly. I can access 7plus 9now YouTube netflix etc but not 10play.

SteveW_52
Level 22: Superhuman
Level 22: Superhuman

Re: 10 Play on Telstra TV

Did you try a manual update on your TTV? Settings |  System  |  Software update?  It checks the firmware and app software and updates as necessary..

Stevo 52
Too many devices, probably an addict 🙂 also a tinkerer and developer of stuff..
Not with Telstra, just another customer like you!
Jupiter
Level 25: The Singularity
Level 25: The Singularity

Re: 10 Play on Telstra TV

It's odd as you definitely have the correct version of the app. When @RokuMalcolm and I checked on my TTV3, I have the same 5.1.2 version of the 10 Play app. When it loads, it reports version 6.5.0 internally.

 

The error message is indicating that the app cannot connect with the 10Play server itself.

 

As an extra piece of troubleshooting, could I suggest that you change the DNS server? It might be that the one that your connection is using does not currently contain the details for the 10Play server.

 

If you change the DNS server settings on your modem to use Google (8.8.8.8), it might fix the problem (I use the Google DNS servers on my system), or at worst, eliminate a cause of the problem.

 

The problem could also be caused if you are using a VPN on your system, or if your IP address is associated with a location outside of Australia (use whatsmyip.com to check the latter).

Never be afraid to back yourself when trying new things, just always make sure you have 3 escape routes if things go wrong.

Telstra TV

Telstra TV helps you find and discover more of what you love.

Find out more